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Ubung A: Erstellen eines Leiterplattenprojektes

Das Programmsystem Altium Designer dient zum Zeichnen von Schaltplénen und zum Leiterplatten-
entwurf. Es beinhaltet unter einer einheitlichen Oberflache die bendtigten Softwarewerkzeuge fir:

Zeichnen von Schaltplanen,
Layoutentwurf (Leiterplattenentwurf),
Entwurf von Symbolen fir Schaltplane,
4. Entwurf von Footprints.
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Anhand einer einfachen Schaltung soll der Designflow beim Leiterplattenentwurf von der Aufnahme
eines Schaltplans bis zur Umsetzung in ein Leiterplattenlayout gezeigt werden.
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In diesem Ubungsteil wird davon ausge- I~
gangen, dass sich alle Bauelementesym-
bole in bereits vorgefertigten Bibliotheken
befinden.
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Programmiuibersicht

Das Programmfenster unterteilt sich in
den Arbeitsbereich A, die Navigationsleis-
te B und die Werkzeugleiste C.

Die Navigationsleiste B gestattet es, Da-
teien bzw. Objekte auszuwahlen. Die ver-
schiedenen Ansichten werden Uber die
Karteikarten (z. B. ,Files’, ,Projects’,
,Libraries’ usw.) im Fenster B unten um-
geschaltet.
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In diesem Tutorial werden folgende Dokumenttypen verwendet, die sich durch ihre Dateiendung zu-
ordnen lassen:

Dateiname.PrjPCB - Projektdatei fir das gesamte Leiterplattenprojekt,
Dateiname.SchDoc — Schaltplandatei (Schematic),

Dateiname.PcbDoc - Leiterplattenlayoutdatei (PCB),

Dateiname.SchLib — Bibliotheksdatei fir die Schaltsymbole im Schaltplan,
Dateiname.PcbLib — Bibliotheksdatei flr das Layout der Footprints.

Zu Beginn sollte der Pfad auf das Arbeitsverzeichnis unter DXP -> Preferences > System > Default Locations
vorgegeben werden (in der Ubung ,D:NAltium*). Alle Projektdateien sollten in diesem Verzeichnis lie-
gen.



I. Eingabe eines Schaltplans (Schematic)

Nach dem Start des Programms Altium Designer wird zunachst ein neues Projekt (PCB Project) und
darin ein neuer Schaltplan (Schematic) unter einem Namen angelegt und gespeichert.

i Altium Designer (14.0) - D:\eigen.dat\TU Doc'Lehrveranstaltung
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Projekt er6ffnen

Schaltsymbole von Bauelementen sind in Bauelementebibliotheken organisiert. Um Schaltungssym-
bole platzieren zu kénnen, muss zuerst die jeweilige Bibliothek (Library) ausgewahlt werden, die das
gewulnschte Bauelement enthalt.

BEEIENE rechte Maustaste ubelzt'iem Projekt —— S 02 om
. 6ffnet ein Kontextmen; dort S um QL i
Add Existing to Project... _Previews
Workspacel.DsnWrk auswahlen | History
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Desktop
% Compile PCE Project Usbungl,
[®= ebungl.5chDoc Add Hew b Projsct .

5 e oot & Einzne Dateien Auswahl des Bibliothekspfades und der }

Save Project As...
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Arbeitzplatz

Dateiname: [Debungt schLb | Uffnen |
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4

Auswahl einer Bibliothek

AnschlieRend kdnnen aus dieser Bibliothek die Bauelemente ausgewahlt und auf dem Schaltplan plat-
ziert werden. Die Taste (Leertaste) dreht das Symbol wahrend des Platzierens, solange es
noch nicht abgelegt wurde.



Projects Auf Bibliotheksansicht umschalten. SCH Library v 1x

Workspacel DsnWik QQSM :rc:l!jlttren i(:!e Karte fehlen, kann sie tiber | =l &
o . Components /| Description
Uebungl.PrjPCE View = Workspace Panels = SCH E | o

o q 2R [l ADs0318R 2.7V, 800ué, 80MHz Rail-to.
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Gewiinschtes Bauelement auswahlen, Place
Button betatigen und Bauelement mit der
Maus platzieren,

bei Bedarf mit ,Space’- Taste drehen,
Platzieren mit ,ESC’- Taste beenden.

Files |

Platzieren (Place) von Bauelementen

Ein Doppelklick auf ein Bauelement 6ffnet einen Eigenschaftendialog. Darin kann unter ,Designator’ der
Bauelementebezeichner (z.B. R15, X1 usw.) und unter ,Models’ die Bauform (,Footprint’, z. B. bei ICs
die Gehausebauform SO8 oder DIL8) vorgegeben werden.

Nachdem alle Bauelemente platziert sind,

kénnen die Schaltsymbole fiir Betriebs-
spannungsnetze Uber die gekennzeichne- @ Rk

ten Buttons in der Symbolleiste erzeugt

werden. i =
Nach dem Platzieren 6ffnet ein Doppel- NET e o =
klick auf das Symbol ein Dialogfenster in oo B o 3
dem die Form (Balken, Kreis usw.) und He LU(...EEWEIEESEZ |
der Name festgelegt werden kann. Der e ene | e 2
Symbolname bestimmt die Zugehdrigkeit

zu einem Netz (z. B. GND, VCC oder +5V). P enanom 7 1o T ‘

Nach dem Platzieren kann verdrahtet wer-
den. Die daflr notwendigen Leitungen er-
reicht man Uber den gekennzeichneten
Button in der Werkzeugleiste. Der Ver- Place Wire]
drahtungsmodus wird mit _der rechten
Maustaste oder der Taste endet. Die ‘

pana

Verdrahtung sollte auf dem Raster erfol-
gen um das zuverlassige Verbinden der
Elemente sicherzustellen.

Der Schaltplan ist jetzt fertig und sollte ge-
speichert werden. Nun werden die logi-
schen Informationen des Schaltplans zu
den physischen Eigenschaften der Bau-

elemente in Beziehung gesetzt, um das
Layout zu erzeugen.



Il. Layoutentwurf

Zuerst muss die Datei flr das Leiterplat-
tenlayout (PCB) erzeugt werden. Das ge-
schieht am besten mit dem daflr vorge-
sehenen Assistenten. Folgende Einstel-
lungen werden eingetragen (Ungenannte
bleiben auf Default):

- Metric > Custom - Rectangular, Width =
40 mm, Height = 20 mm, Title Block: aus,
Legend String: aus, Dimension Lines: aus

-> 2 Signal Layers, 0 Power Planes

- Thruhole Vias only

-> Surface mount components,

Components on both sides: No

- Leiterzugdimensionen: Default

- [Finish].

Danach wird das Dokument gespeichert
File > Save As.. 2 [Uebung1.PcbDoc].

Dieses Dokument wird anschlieRend per
“Drag and Drop” dem Projekt zugeord-
net.

Als nachstes wird die Footprintbibliothek
[Uebung1.PcbLib] geladen. Die Vorgehens-
weise ist die gleiche wie bei der Symbol-
bibliothek.

Die Footprint- Bibliothek enthalt Informa-
tionen zu den Abmessungen der An-
schlussflachen (engl. Pads), zum Gehause
und zur Mechanik (z. B. Befestigungsboh-
rungen oder Ausfrasungen) fir das jewei-
lige Bauelement.

/Nach Auswahl der Registerkarte ,Files’\
kann dort unter ,New from template’
der Assistent ,PCB Board Wizard’ ge-
startet werden

New from template
B8 pcB Templates...
[ schematic Templates...

sl pcs ije.ds”' liber das Mend mit:
@1 FPGA Projects... View = Workspace Panels > Sys-

{3 Core Projects... tem > Files aktiviert werden. /
i) Embedded Projects...
B8 pCP Board Wizard.

- D

Anm.: sollte die Karte fehlen, kann sie

% FileView (" Structure Editor ® |
@3l Uebung LPIiPCB *
=1 source Documents
= Uebungl. freve

=L Libraries »
EL Schematic Lib Documents
2 Uebungl Schlib

Zuordnen der neu er-

stellten Leiterplatten- =4
layoutdatei zum Projekt ST ULl L
(Drag and Drop) -

Warkspacel.DsnWrk
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Workspace .

Uebung1.PrjPCB Project

@ FileView " stuctureEditor @ | (4=
— ]

“1UebungLPriPCB
L1 Source Documents ¥ Compile PCE Project Uebungl . PriPCE

L5 Uebungl.PcbDoc

2 uebung1.5chDoc

88 tibraries | % add Existing to Project...
= Schematic Library D Save Project

Add New to Project »

rechte Maustaste tiber dem Projekt 6ffnet ein Kontextmend;
dort den Punkt Add Existing to Project... auswahlen

Auswahl der Footprint- Bibliothek ,Uebung1.PcbLib’

Nun kann aus der logischen Struktur des Schaltplans eine Netzliste generiert und jedem Bauelement
das passende physische Modell (Footprint) zugeordnet werden.

Man wahlt dazu:

Design - Import Changes from, Execute
Changes, Close.

Der Nullpunkt des Koordinatensystems
wird durch

Edit > Origin > Set

in der linken unteren Ecke der Leiterplatte
positioniert.

Room: Anklicken, Léschen
(Taste 'Del' bzw. 'Entf')

Das entstehende rote Feld um die Bauelemente (Room) dient der Strukturierung grofRer Schaltungen
und sollte bei einfachen Projekten geldscht werden.




Raster (engl. Grids) dienen dem Ausrichten
von Bauelementen. Uber die Tastenkombi-

 Cartesian Grid Editor [mm] 211

Settings

nation Iésst sich der Dialog zum e '——'=
Einstellen des Rasters 6ffnen. Hier wird ein weroecs oo e

geeignetes Raster eingestellt, z. B.:

Step X auf 0,127 mm (5 Mil) und
Step Y auf 0,127 mm (5 Mil) setzen.

Auf diesem Raster werden die Bauele-
mente und die Leiterzlge verlegt.

Step X £3 ’gﬁtst:pxw PCB View..

Die Footprints kdnnen nun einzeln mit der
rechten Maustaste ausgewahlt und auf der
Leiterplatte angeordnet werden. Dabei
lasst sich die Orientierung (Drehung) mit
der Taste | sie | festlegen. Bei der Plat-
zierung sollte auf eine glnstige Lage der
Bauelemente untereinander bzw. auf eine
glnstige Position von Steckern, Anzeige-
und Einstellbauelementen, Kuahlkorpern
usw. geachtet werden. Leiterzugslangen
insbesondere von kritischen Signalen sind
dabei zu minimieren.

Im Anschluss werden die Gummibander (engl. Airwires) geroutet, d. h. den bisher symbolischen Lei-
terzligen werden konkrete Positionen zugeordnet. Mit Durchkontaktierungen (engl. Vias) lassen sich
Leiterziige unterschiedlicher Ebenen miteinander verbinden.

Nach Auswahl des gewlnschten Layers
(Top = Oberseite oder Bottom = Unterseite
der Leiterplatte) erreicht man die interaktive
Verdrahtung (Routing) Uber das markierte
Symbol.

Nach Anwahl dieses Symbols werden die
Leiterzige mit der Maus verlegt. Zwischen
den Layern kann wéahrend des Routens
Uber die Ziffernblock-Taste |@| gewechselt
werden. Vias (Durchkontakte) werden da-
bei automatisch erstellt. Die Taste
'smce | Wechselt den Vorzugswinkel der
Leitungen beim Routen. Der Modus wird
mit esshder der rechten Maustaste beendet.

Sind alle Leitungen geroutet, wird die Leiterplattenlayoutdatei gespeichert. Danach kann die Verdrah-
tung mit dem Punkt Tools = Design Rule Check... Gberprift werden. Treten hierbei keine Fehler auf, kann
jetzt die Dokumentation der Ergebnisse erfolgen:

= Erstellen eines Unterlagensatzes: Schaltplan, Bestlickungsplan, Layouts der Einzelebenen,
= Erstellen der Gerber- Files und evtl. weiterer Unterlagen fir die Leiterplattenproduktion,
= Stlcklisten, Einkaufslisten.



Ubung B: Erstellen eines eigenen Bauelementes

Viele Bauelemente sind keine Standardbauelemente. Die Footprints und Schaltsymbole missen dann
selbst erstellt werden. Als Beispiel soll in dieser Ubung der Footprint und das Schaltungssymbol eines
Mikrocontrollers vom Typ STM32G491KCUG [1] der Firma ST Microelectronics in der Gehausebauform
LQFP48 erstellt werden.

Da die Zuordnung der Anschlisse (engl. Pins) des Schaltsymbols zu den Anschlussflachen (Pads) des
Footprints Uber die Pinnummer geschieht, sollte sorgfaltig auf die richtige Nummerierung geachtet
werden.

l. Erstellen eines Footprints

Der Footprint stellt die Gesamtheit der Informationen zu den Abmessungen und der Anordnung der
Pads, Freiflachen, Bohrungen etc. dar, die bendtigt werden, um das Bauelement im Leiterplattenlay-
outprogramm routen zu kénnen.

Eine Auswahl von Footprints befindet sich

im Lieferumfang des Programms und steht

nach Einbinden der Bibliotheken zur Verfu- c . Footprint
gung. Hier soll jedoch davon ausgegangen 11 :s---{ UFQFPN32
werden, dass ein neuer Footprint flr die . = —ta mm
Gehéusebauform UFQFPN32 erzeugt wer- -+ . ! A 03
den muss. _ _ R — %** B 06
Grundlage sind die Layoutempfehlungen ! 5 : c 05
der Hersteller fur die GroRe und Lage der | ___“i___J ’
Pads, die meistens im Datenblatt des Bau- i D 47
elements zur Verflgung gestellt werden.

Die Layoutempfehlungen kénnen von der

angestrebten BestUCkungstechno|ogie ab- FOOtprint zum Gehéuse UFQFPN32 (4 x8 AnSChlusse) [1]

hangen.

Zunachst wird eine neue Footprintbibliothek erstellt. Darin wird dann das neue Footprint angelegt.

Eile | Edit view Project
I

Hew »

~ open.., Cti+0

Impart,

Danach starten des Komponenten- AA

Erstellen einer neuen Footprintbibliothek sistenten durch:

File > New -> Library > PCB Library
Bibliothek benennen und speichem

File > Save As... > [Bibliotheksname]
hier z.B. .Uebuna2.PcbLib’...

Tools - Component Wizard, Next,
Auswahl folgender Einstellungen:
QUAD und Metric (mm) >

Pad- Abmessungen laut Datenblatt:
Breite (B) = 0.6 mm,

Hohe (A) =0.3 mm >

Padform - default >
Begrenzungslinie — default >

Pad- Abstande laut Datenblatt jeweils:
Pad zu Pad (C) = 0.5 mm,

Pad zu Rand = 0.6 mm, >
Zahlrichtung - default >

Pin-Anzahl: X=8,Y =8 >

Name: UFQFPN32 - [Finish],

{bsoeichern: File > Save /

1 TextDo
S5 caMDocur
I+ Output Job File

Dakabase Link File:

|2

— | Project

Lbrary

Seript Files

schematic Dhary
| & PcB Library
VHDL Library

-Sinnal Simulation

| e

Neues Footprint erstellen




Il. Erstellen eines Schaltsymbols

Danach wird das neue Schaltsymbol flr den Mikrocontroller erstellt.

Erstellen einer neuen Bauelementebibliothek
File = New = Library = Schematic Library
Bibliothek benennen und speichern

File > Save As... - [Bibliotheksname]
hier z.B. ,Uebung2.SchLib’,

T TetDocoment
4% CAMDocument
1 Output Job File

2 Database Link File
Project..
Library v | Component Librd
Seript Files * [S schematic Library [y |
Miged-Signal Simulation » |2 pceLibrary
* |5 VHDL Library
crilog Librar

@D

N4

‘ 13 | Files | Projects | Mavigaf

X-110Y:-20 Grid:10

Auf Bibliotheksansicht um-
schalten und...

SCH Library

| V&

Components

Delete

Place Edit

Hinzufiigen eines
Footprint-Modells,

& Add New Model

¥

Default Designator |07 MAvisisle [Jtocked ;:’;“
Default Commene [STM32G431KCUE | Mvisible ““"‘f
Patin Cltockes s
Troe Standard v
Symbel Reference [ST32G451KCU = e L SRR
Graphical Models
i [
Mode HLock Fins®
(N} ftven
Duwcat cotors X " X
Informationen fiir das Bauelement ein-
tragen, z.B.: Default Designator: D?,
e Svmbol Reference: STM32G491KCU

Models Model Type

Name Footprint

Browse Libraries

danach alle Dialoge
mit OK verlassen.

Libraries| # Usbungz Peolin 4 v Find.
/
Mask e
Mame 7 ubrary
[ I  <ouno2 Peoiin
innnnnnn
| |
Auswahl der - -
Footprint-Bibliothek, hier - -
"Uebung2.PcbLib’ und = -
des zuvor erstellten Foot- - - -
prints ,UFQFPN32’ = TITI11] =
< >
,

Schaltsymbol erzeugen, Daten eintragen




Nachdem das Bauelement angelegt ist, und die Daten eingetragen wurden, kann das Symbol gezeich-

net werden.

Mode -

& Uebung2.schlib = %

Rechteckigen
Symbolumriss
zeichnen...

...und Pins platzieren, dabei bei
Bedarf mit der ,Space’- Taste dre-
hen. Das Fadenkreuz markiert den
elektrischen Anschluss.

Ein Doppelklick auf das Pin 6ffnet
den Eigenschaftendialog:

Hier wird der Name, die Ausrich-
tung und das elektrische Verhalten
der Pins (Ein- / Ausgang, Versor-
gungsspannung) anhand des Da-
tenblatts eingestellt.

Bsp.: ,VDD'; Pin 1; power — 13,

\ [PAC’; Pin 5; 110 J — 20,
27

——=— VDD

VDD
VDDA

VSSA
VSS
VSS

PBO
PB3
PB4
PBS
PB6
PB7
PB8_BOOTO
PFO
PF1
PG10_NRST

PAO
PA1
PA2
PA3
PA4

PA6
PA7
PAS
PA9
PA10
PA1l
PA12
PA13
PA14
PAILS

T

?;

f:

el fid| fi
o |colto

i

!
\S]

i

Logisches Anordnen der Pins It.
Datenblatt, Abspeichern!

Schaltsymbol zeichnen

Hinweis: Die Zuordnung zwischen Layout-Pad und Anschluss des Symbols erfolgt durch Zuweisen des

gleichen Bezeichners (im Feld ,Designator’).

So erstellte Bauelemente lassen sich nun in anderen Projekten nutzen, nachdem die beiden Bibliothe-

ken, wie in Ubung 1 beschrieben, zum Projekt hinzugefligt werden.




Quellen

[1] Datenblatt fur Mikrocontroller STM32G491KCUG
https:/lwww.st.com/resource/en/datasheet/stm329491kc.pdf (25.3.2025)

Glossar

Airwires
Bottom
Button
Component

default (Einstellung)

Drag and Drop

Designflow
Footprint

Grid
Layer
Library
Mil

Pad

PCB

Pin

Routen
Schematic
SMD-Bauelement
Space (Taste)

Symbolische Darstellung der Verbindungen (Gummibéander)
Unterseite der Leiterplatte

Grafisches Symbol, Schaltflache im Programm

Bauteil

Standardeinstellung — ,,auf Voreinstellung lassen”

In grafischen Benutzeroberflachen: Ziehen einer Datei zu
einem Ziel mit der Maus

Schrittfolge bei Projektbearbeitung in einem Entwurfssystem
~FulBabdruck” des Bauelements auf der Leiterplatte -
Gesamtheit der Pads, Bestlickungsaufdrucke usw.
Raster

Zeichnungsebene, z. B. Mechanik-Layer oder Top-Layer
Bibliothek

im Layoutentwurf Ubliche Langeneinheit:

1 Mil = 1/1000 Inch, d. h. 0,0254 mm

Anschlussflache eines Bauelements auf der Leiterplatte
.Printed Circuit Board” — Leiterplatte, Platine

einzelner Anschluss eines Bauelements

Verlegen von Leiterzligen

Schaltplan, Stromlaufplan

Surface Mounted Device

Leertaste

Top Oberseite der Leiterplatte; meist Bestlickungsseite
Via Durchkontakt
Shortcuts
Funktion Tastenkombination
Zoomen 'Strg' + Mausrad oder 'Bild T bzw. 'Bild {"
Kopieren ‘Strg' + 'C'
Ausschneiden ‘'Strg' + ‘X'
Einflgen ‘Strg' + 'V
Aktion rdckgangig (Undo) 'Strg' + 'Z'
Aktion wieder herstellen (Redo) 'Strg' +'Y!
Drehen eines ausgewahlten Objektes ‘Space' (Leertaste)
Eigenschaftendialog zu einem Objekt ‘Tab'
PCB: Layerdialog L
PCB: Einheiten Mil / mm umschalten Q'
PCB: Raster einstellen ‘G
PCB: Abstand Messen 'Strg' + 'M'
PCB: Single / Multi-Layer Mode ‘Shift' + 'S
PCB: Layout-Ansicht / 3D-Ansicht '2'/'3
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Dieses Dokument wurde zur Nutzung mit dem Programm ,, Altium Designer 14" erstellt.




